Troubleshooting
Problem
This technote explains why the IBM® Rational® ClearCase® logs identify database error []db_vista -905[] and provides instructions to resolve the problem.
Symptom
The following errors may be seen at times in the view_log:
10/30/00 11:47:40 view_server(27256): Ok:
10/30/00 11:47:40 view_server(27256): Ok: *** db_VISTA database error -905 - error opening file
10/30/00 11:47:40 view_server(27256): Error: could not locate view database component (op 'D_SYNCFILES')
The following error messages may also be seen in the vobrpc_log:
2/1/2008 3:14:37 PM vobrpc_server(5764): Error: vobrpc_server.exe(5764): Error: Trouble opening VOB database: "\myvob".
2/1/2008 3:14:37 PM vobrpc_server(5764): Error: vobrpc_server.exe(5764): Error: Error from VOB database: "\myvob".
2/1/2008 3:14:37 PM vobrpc_server(5764): Error: vobrpc_server.exe(5764): Error: Cannot open database in "C:\ccstg_c\vobs\myvob.vbs\db"
2/1/2008 3:14:37 PM vobrpc_server(5764): Error: vobrpc_server.exe(5764): Error: db_VISTA error -905 (errno == "No such file or directory")
2/1/2008 3:14:37 PM vobrpc_server(5764): Error: vobrpc_server.exe(5764): Error: DBMS error in C:\ccstg_c\vobs\myvob.vbs\db.
2/1/2008 3:14:37 PM vobrpc_server(5764): Warning: *** db_VISTA database error -905 - error opening file
2/1/2008 3:14:37 PM vobrpc_server(5764): Warning: *** db_VISTA database error -914 - error reading from a database/overflow file
Cause
Cause 1
The db_VISTA database error -905 refers to the s_NO_FILE_FOUND construct which means that the view server process is unable to find the view db files.
Cause 2
This error message also appears when one or more of the database files view_db.d0* are missing from the view storage database directory.
Cause 3
The db_VISTA -905 errors can also occur when one or multiple vob_db.d0* files are 0 bytes in size.
Note: A possible scenario for this situation to occur is if a recent restore from backup was performed and the backup did not contain any data in these files.
Cause 4
This error may be caused by the issue reported in defect APAR PK75289: IBM Rational ClearCase cleartool rmview can cause a race condition with terminating view_server process on removal
Resolving The Problem
Solution 1
Find and kill the stale view_server process using standard operating system commands (kill on UNIX® and Linux® and the End Process command from the Task Manager on Microsoft® Windows®).
Consult your system administrator for assistance if required.
Hint: Use the albd_list utility to assist with identifying which ClearCase server process maps to a particular pid. Review technote 1148639 for more information on the albd_list utility and its usage.
Solution 2
List the contents of the database directory (db) to ensure that the following files are present in the database directory:
- view_db.d01
- view_db.d02
- view_db.d03
If one or more are missing, restore the view from a known good backup; otherwise, remove the view and create a new one.
Solution 3
Check the vob_db.d0* files and if any of them are 0 bytes in size, the VOB will need to be restored from a good backup.
Solution 4
Defect APAR PK75289 has been resolved in ClearCase 7.0.0.6, 7.0.1.5 and 7.1.0.2
Related Information
Was this topic helpful?
Document Information
Modified date:
29 September 2018
UID
swg21123744