Troubleshooting
Problem
This technote explains why attempts to use IBM® Rational® ClearCase® Remote Client (CCRC) or ClearCase Web (CCWeb) result in []Permission denied[] errors along with instructions to resolve the issue.
Symptom
Attempts to use CCRC or CCWeb result in the following errors:
Unable to access the version data for "C:\ccweb\user1\xyzzy\noncomp\makefile": error detected by ClearCase subsystem ccweb: Error: Operation "fileutl_tmpfile_ext_binary" failed: Permission denied.
Note: If the user with this problem is granted Administrator rights to the Web server, the issue appears resolved, but will reoccur as soon as those rights are removed.
Another symptom appears while attempting to edit the config spec or create a new view.
Edit config_spec:
The GUI will erroneously show that there are NO version selection rules.
Adding in rules and attempting to update the view results in the error:
Problems performing setcs.
ccweb: Error: Unable to create temporary file: Permission denied.
Creating a new view:
Unable to create the view at c:\ccweb\user1\view1
Error detected by clearcase subsytem
Created view
Host: local path: host1
c:\ccweb\user1\view1\view.s
Created a snaphost view directory
errors - unable to create temporary file - permission denied
Cause
The cause of these problems relates to ClearCase using a directory for temporary files where the user who is accessing the server does not have the rights necessary to create temporary files.
Resolving The Problem
Edit the ccweb.conf file and edit the line:
-tmpdir {Drive and directory where users have "full control" rights}
Review technote 1125332 for more details about the ccweb.conf file.
Related Information
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Document Information
Modified date:
29 September 2018
UID
swg21143558