IBM Support

Exchanging diagnostic information with IBM Technical Support for problem determination

Troubleshooting


Problem

This document describes how to submit diagnostic information to IBM so problem determination can begin for a CICS support case.

Cause

You open a case to get help with a CICS problem from IBM Support. To find a solution, Support needs problem determination data (diagnostic data) such as CICS MustGather data.

Resolving The Problem

Exchanging information with IBM Technical Support:

Notes


If you need to speak to an IBM technical support representative, call your country representative.

If you need to speak to an IBM technical support representative in the US, call 1-800-IBM-SERV.

 

 



 
 

Sending information to Support

Refer to ECuRep - Send Data Service for instructions on how to send diagnostic information such as log files, traces, and dumps to IBM Technical Support.

For CICS system dumps and logs, terse and FTP in binary. 
For CICS auxtraces, send the raw auxtrace tersed in binary.


Important Notes:

  • Effective 31 August 2022, all uploads of documentation to both the IBM testcase and ecurep servers' /toibm directories will require an authenticated log-in using an IBM Support File Transfer ID and password (token).  For more information, see Unsecured and anonymous FTP to upload IBM documentation will be disabled.
  • On 27 July 2020, the plain FTP servers, ftp.ecurep.ibm.com, and ftp.ap.ecurep.ibm.com, are discontinued for manual data upload.  Only authenticated FTPS (FTP over TLS) and SFTP (FTP over SSH) are supported for manual FTP uploads.
  • Data delivered electronically to IBM must be in compressed format. You can use the AMATERSE service aid to terse the files.  The z/OS utility z/OS Problem Documentation Upload Utility (PDUU) is another option you can use to compress, optionally encrypt, and transfer the data to IBM. 
  • Do not FTP your files to this server unless you have already opened a problem record with the support center. The support representative working on your problem will request your data.
  • You can create a file (for example, using the put or mput command), but you cannot update it. So, you will need to create a new file with a unique name. Include your case number as the first part of the file name.
  • You cannot receive information from the directories where you put files (get or mget command). The information you submit is only available to the IBM technical support representatives.
  • If the data set is encrypted, the decryption key should be included in a case update or an email sent to [email protected]. The case number should be included in the subject line when provided by email



 

 


 

Emailing files directly to ECuRep

For select IBM products, including CICS, you can attach your diagnostic data to a note and email it to the ECuRep Mail Gateway. If the data you send (outputs, traces, compressed file, etc.) is less than 20 MB, you can email it to IBM Technical Support by performing the following steps:

  1. Create an email message addressed to the following email address:
    [email protected]
  2. Your case number must appear somewhere in the Subject line:
    optional_text TSxxxxxxxxx optional_text
    where:
      TSxxxxxxxxx  is the case number 
      optional_text is any other text that helps describe the contents of the email

    Examples:
    TS012345678
    TS012345678 - requested traces
    Case # TS012345678
    Case # TS012345678 - odstat.txt and logs
    Case
    TS012345678 here are the testcase files

    If you do not already have a case number, put the product name in the Subject string.
  3. In the body of the message, put a brief description of the problem symptoms and describe the files you have sent in.
  4. Attach the files, outputs, information, and (or) compressed file to the message.
  5. You will receive an automated reply once your email is processed. If your email cannot be associated to an existing case, it will be tagged as lost and eventually deleted.


Depending on your internet connection and email server, allowable attachment file might be significantly less than the 20 MB limit. When in doubt, you can simply use the FTP steps to ensure timely delivery of your files.
 



 

VSE specific FTP server instructions for binary dumps

  1. Load dumps from stand-alone dump tape/disk into dump library:
    System and stand-alone dumps are stored in binary format in the VSE system dump library or on a stand-alone dump tape or disk. The binary format is the preferred format by IBM for problem analysis. To send a stand-alone dump, first move the dump files into the VSE system dump library using the Interactive User Interface (IUI) dialogue "Storage Dump Management". If your system does not have IUI then use the JCL job example in Appendix A (tape) and Appendix B (disk), which are included in the  attachment.
  2. Download the dumps from your VSE system to your PC as binary data:
    Use the RECEIVE function to download the dumps as binary data to a PC. During download, rename the files according to the IBM “file naming convention“. The “file naming convention” allows the IBM internal support tools to link the uploaded data with the assigned case (for example, diagnostic data for case TS012345678 must be named TS012345678.yyyyyyyy.zzz).
  3. The following example command shows how to rename and download the file sad00003.dump from sublibrary SYSDUMP.BG to your PC as TS012345678.sad00003.bin to the current PC directory:
    1. Logon session "A" to VSE and enter native CICS or fastpath 386 (for administrator) = "PC File Transfer".
    2. At a PC command window enter:
      receive TS012345678.sad00003.bin a:sad00003 dump (file=lib l=sysdump s=bg binary)
      (It is not recommended to zip these binary files.)
  4. Use the FTP command to put your files onto the IBM designated server:
    (The following instructions do not include steps that might be necessary to pass through a firewall or proxy server.)
    1. Enter ftp ftps.ecurep.ibm.com on a TSO or Windows® command line. If this server is not available, you can use this back-up server: ftp testcase.boulder.ibm.com
    2. At the User: prompt, login with your IBM ID and password.
    3. Enter cd toibm/vse/ to change the directory.
    4. Enter: bin to set the transfer mode to binary for binary files such as non-formatted dumps and trace. Use the default ASCII type transfer mode for text files such as formatted dumps and trace.
    5. Enter: put 'your_file' to put your_file on the server. Use the following naming convention to name your_file. Your case will be updated to list where files are stored, using the format: TSxxxxxxxxx .yyy.yyy.[TRS][.CRY / .CRY64 ]

      Where:
      TSxxxxxxxxx  = Case number
      yyy.yyy = Description of the file type.
      TRS = Mandatory identifier for a tersed file
      CRY = Optional additional Identifier for non-DES Encrypted file (FTPENCR module)
      CRY64 = Optional additional Identifier for 64-bit DES Encrypted file (FTPENCRD module)
      AWS = Required additional identifier for a z/VSE virtual tape image file

      Example:
      put 'DSNAME.TRS' TS012345678.DUMP.TRS

      These file naming conventions are documented under Enhanced Customer Data Repository (ECuRep) - Prepare data.

      The correct syntax must be used in order for the tool to update the case correctly.

      A z/VSE Virtual Tape binary image file from a distributed system can be sent directly to IBM, but make sure that it has the correct name and the .AWS identifier at the end.
    6. Repeat the upload for each file.
    7. Enter quit command.
    8. The case matching the file names will be updated automatically with the names of the transferred files. Additionally you can inform VSE software support that data has been sent.



 

VSE specific FTP server instructions for text format

Printed dumps and traces are in text format and reside in the VSE/POWER LST queue with variable record length. When sending a LST output to IBM service using FTP, the record structure must be preserved. This is achieved by transferring the data with the CRLF option (Carriage Return Line Feed) to a PC or Workstation and compressing it there (using zip).

  1. Download the printed data from your VSE system to your PC
    Use the RECEIVE function to download the listing(s) as text data to a PC. During download, rename the file(s) according to the IBM “file naming convention“. The “file naming convention” allows IBM to link the uploaded data with the assigned case (for example, diagnostic data for case TS012345678 must be named TS012345678.yyyyyyyy.zip).
  2. The following example command shows how to download and rename the VSE/POWER LST queue entry PRINTOUT with job number 00123 to your PC as TS012345678.printout.txt to the current PC directory:
    1. Logon session "A" to VSE and enter native CICS or fastpath 386 (for administrator) = "PC File Transfer".
    2. At a PC command window enter:
      receive TS012345678.printout.txt a:printout 00123 (file=lst ascii crlf
    3. Zip the text files and change the file type to “zip”.
       
  3. Use the FTP command to put your files onto the IBM designated server:
    (The following instructions do not include steps which may be necessary to pass through a firewall or proxy server.)
    1. Enter ftp ftps.ecurep.ibm.com on a TSO or Windows command line. If this server is not available, you can use this back-up server: ftp testcase.boulder.ibm.com
    2. At the User: prompt, login with your IBM ID and password.
    3. Enter cd toibm/vse/ to change the directory.
    4. Enter: bin to set the transfer mode to binary for binary files such as non-formatted dumps and trace. Use the default ASCII type transfer mode for text files such as formatted dumps and trace.
    5. Enter: put 'your_file' to put your_file on the server. Use the following file naming convention to name your_file. Your case will be updated to list where files are stored, using the format: TSxxxxxxxxx.yyy.yyy.[TRS][.CRY / .CRY64 ]

      where:
      TSxxxxxxxxx  = Case number
      yyy.yyy = Description of the file type.
      TRS = Mandatory identifier for a tersed file
      CRY = Optional additional Identifier for non-DES Encrypted file (FTPENCR module)
      CRY64 = Optional additional Identifier for 64-bit DES Encrypted file (FTPENCRD module)

      Example:
      put 'DSNAME.TRS' TS012345678.dump.TRS

      These file naming conventions are documented under Enhanced Customer Data Repository (ECuRep) - Prepare data.

      The correct syntax must be used in order for the tool to update the case correctly.
    6. Repeat the upload for each file.
    7. Enter quit command.
    8. The case matching the file names will be updated automatically with the names of the transferred files. Additionally you can inform VSE software support that data has been sent.

Appendix.txt

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"ARM Category":[{"code":"a8m0z00000007cXAAQ","label":"CICS Transaction Server"}],"Platform":[{"code":"PF035","label":"z\/OS"},{"code":"PF038","label":"z\/VSE"}],"Version":"2.2.0;5.2.0;5.3.0;5.4.0;5.5.0;5.6.0","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

CICS/TS CICS TS CICS Transaction Server CICS/VSE CICS VSE z/VSE

Document Information

Modified date:
01 March 2022

UID

swg21204910