IBM Support

Can't get primary group SID

Troubleshooting


Problem

When running the IBM® Rational® ClearCase® creds utility, the output appears normal except under the Primary Groups section it reports "can't get primary gid". This technote attempts to explain the reasons why as well as what can be done to resolve the problem.

Symptom

The creds utility (located by default in C:\Program Files\Rational\ClearCase\etc\utils ) reports output similar to the following:

*****

C:\>"C:\Program Files\Rational\ClearCase\etc\utils"\creds
Login name:    DOMAIN\user1
USID:          NT:S-1-5-21-1607275091-1726037764-648285020-1004
Primary group: *** Can't get primary group SID
Groups: (7)
   DOMAIN\None (NT:S-1-5-21-1607275091-1726037764-648285020-513)
   Everyone (NT:S-1-1-0)
   BUILTIN\Administrators (NT:S-1-5-32-544)
   BUILTIN\Users (NT:S-1-5-32-545)
   LOCAL (NT:S-1-2-0)
   NT AUTHORITY\INTERACTIVE (NT:S-1-5-4)
   NT AUTHORITY\Authenticated Users (NT:S-1-5-11)

You do not have ClearCase administrative privileges.
You are not logged into Windows NT domain.



You may also see output similar to the following:

*** Can't get primary group SID
*** You may not be a member of the "<group>" group.
*** Can't get group info for current process primary group SID "NOBODY"


Note: You may also see the primary group is set to a group name that is NOT what is referenced in the variable.

Cause


Check for one of the following problems is occurring:

  1. You are logged into a domain but there is a local clearcase group and a local clearcase_albd user.

    See the Administrator's Guide on the section that discusses ClearCase and Windows® Domains for more information.
  2. The CLEARCASE_PRIMARY_GROUP user environment variable may not be set correctly.
  3. You are not a member of the primary group.
  4. If you encounter the error Can't get primary group SID when running ClearCase 7.1.1 on Windows 7, it may be related to the issue reported in Microsoft Article 976494.

Resolving The Problem

For Cause 1

Delete the local clearcase_albd user and clearcase group and add these accounts as global accounts from the domain, if they do not already exist.

For Cause 2

Run the set command from the command prompt to read what the CLEARCASE_PRIMARY_GROUP is set to and ensure the spelling and case of the group name is correct.


For Cause 3

Add the group to your group list on the Windows Domain Controller. See your Windows Administrator for more assistance.

For Cause 4

Apply the fix for the issue reported in Microsoft Article 976494.

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Document Information

Modified date:
29 September 2018

UID

swg21122432