IBM Support

Checkin of Library client volumes on a Library manager server

Troubleshooting


Problem

If volumes are not checked in properly, a volume may inadvertently be used by both a library manager and one or more library clients.

Cause

Tivoli Storage Manager volumes not checked in with correct ownership

Resolving The Problem

In a Tivoli Storage Manager library sharing environment., volumes that belong to Library clients are also stored in the volume history of the library manager. They will be stored with type of "remote" and the location field will record the name of Library client owning the volume.
When a checkin libv command is issued, a validation is done on the owner field. If the owner field is not specified, the volume ownership is set to the owning library client, as recorded by the "remote" entry in the volume history of the library manager.

In the event that the library manager does not have a "remote" entry in its volume history, it would be necessary to specify the owner=<libraryclient> parameter on the checkin command and identify the correct library client that owns the volume. This may be necessary for example when the library manager database is restored at a point in time where the remote entry did not exist.

In the case where the library inventory is "out of sync" between library client and library manager, running an AUDIT LIBRARY command on the library client will synchronize the library inventories.

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Document Information

Modified date:
17 June 2018

UID

swg21170083