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Probe id XC338001 FDCs reporting SIGTERM

Troubleshooting


Problem

Your queue manager ended as a result of the server being rebooted. You restarted your queue manager and noticed many FDCs with probe id XC338001, component xehAsySignalHandler:

Symptom

Example of FDC:
Probe Id :- XC338001
Component :- xehAsySignalHandler
Major Errorcode :- xecE_W_UNEXPECTED_ASYNC_SIGNAL
Comment1 :- SIGTERM
+-------------------------------------------------------
MQM Function Stack
xehAsySignalMonitor
xehHandleAsySignal
xcsFFST

Cause

The server was rebooted without first shutting down the queue manager.

Resolving The Problem

This is working as designed.
You need to shut down your Queue Managers before rebooting the system to avoid these FDC reports.

Additional information
Usually there were many reports of this type of FDC from various WebSphere MQ processes and all these reports were created within a few seconds. The server was rebooted without shutting down the queue manager. Under these conditions it is expected, and desirable behavior to produce the FDCs.



Such FDCs are to record the fact that an MQ process (that is, the process that writes the FDC file) has received an asynchronous signal. These FDCs do not indicate a problem originating within MQ and they are "informational"; that is, they are not an indication of any MQ failure at all.

[{"Product":{"code":"SSFKSJ","label":"WebSphere MQ"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Shutdown","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"9.0;8.0;7.5;7.1;7.0.1;7.0;6.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

92378 278 000

Product Synonym

WebSphere MQ WMQ MQSeries

Document Information

Modified date:
15 June 2018

UID

swg21193049