IBM Support

Installing WebSphere Business Integration Adapter Framework and WebSphere Business Integration Adapters on Windows XP or Windows Vista platforms

Troubleshooting


Problem

When installing WebSphere® Business Integration Adapter Framework or WebSphere Business Integration Adapters on Windows® XP and Windows Vista platforms, you might encounter the following installer error message: BIA01002: You have attempted to install IBM WebSphere Business Integration Adapter for on an unsupported platform. Refer to the Installation Guide for WebSphere Business Integration Adapters.

Cause

This is because these products did not support Windows XP or Vista platforms at the time the products were released. The product installers have built-in platform checks that prevent users from installing on unsupported platforms.

Resolving The Problem

To bypass the installer platform check, follow these steps:
1. Open a Command Prompt. (Click Start > Run and then type cmd and click OK.)
2. Change directories to the directory where the installer.exe file is located.
3. Type: setupwin32 -W unsupportedPlatform.active=false
Alternatively, if you want to start the installer using Java®, type:
java -jar setup.jar -W unsupportedPlatform.active=false

[{"Product":{"code":"SSMKUK","label":"WebSphere Adapters Family"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Adapter \u2013 Non-specific","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.6","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSMKUK","label":"WebSphere Adapters Family"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
15 June 2018

UID

swg21258416